jump to navigation

Cox screws the pooch again January 25, 2007

Posted by truthspew in Cox, high-speed my ass, internet.
1 comment so far

*** UPDATE *** Well – the fourth Cox technician came out today, three hours early I might add. I was bringing the new cat for her first visit with the vet – and of course that news was that for $300-$600 she needs dental work, and oh, maybe we should do a CBC etc to the tune of $300. I told the vet the CBC wasn’t indicated, and of course this is the same vet that I had to tell to do an ear swab because the little cat has ear mites.

So I told the Cox tech to check the outside plant and sure enough he calls me back and tells me that the trap and filter on the pole was bad. Amazing that it took four people to figure this out.

*** UPDATE ENDS ***


I’ve been down for four days now. During those four days I’ve had visits from three Cox technicians. The first two re-cabled my entire place. That did nothing.

The second one showed me the Edge Health record for my address and area – no problems. But I found the lie to that this evening. Right now I’m using the connection of a nameless Cox subscriber and the picture above tells the whole story. That’s right, they’ve had the same upstream problems I’ve had. I can’t wait to see the Cox technician on Saturday.

What Cox doesn’t realize is that I’ve steered $33,600 a year towards them at work. It would be just as easy for me to go and talk to a company I really can’t stand (I.E. Verizon) and negotiate better bandwidth for the same or lower cost. Granted, they get about $480 a year out of me for my personal account, but I bet that almost $37K a year will get their attention.

But it gets even better, as of 6:43 this evening my connection miraculously came back online, same as it’s done over the past few days. So there’s something on my node doing in my network connection. I’m going to have fun with the Cox tech on Saturday.

Advertisements